Sven Helpdesk

Forum Forum Allgemeines Öffentlich Sven Helpdesk

Dieses Thema enthält 9 Antworten und 3 Teilnehmer. Es wurde zuletzt aktualisiert von Profilbild von Stefan Stefan vor 5 Jahre, 8 Monate.

Ansicht von 10 Beiträgen - 1 bis 10 (von insgesamt 10)
  • Autor
    Beiträge
  • #647
    Profilbild von Stefan
    Stefan
    Moderator

    Sven, ich hab hier @work das Problem, dass ich wget über unsern Proxy zum laufen bringen muss.

     

    Laut Anleitung und Google sind einfach http_proxy und https_proxy in den Umgebungsvariablen zu setzen und alles sollte laufen.

     

    Dummerweise tut es das aber nicht. Ich bekomme immer eine 407. Der Proxy wird also erkannt, authorisiert mich aber nicht.

     

    Woran könnte das liegen?

    Irgendwas mit der Domäne?

    Die Variablen sind auf http://user:passwort@proxy.corp.com:8080 gesetzt

    brauch ich irgendwie sowas: http://Domäne\user:passwort@proxy.corp.com:8080

    #4542
    Profilbild von Mage
    Mage
    Moderator

    Sorry, war den ganzen Tag unterwegs. Hm, ich fürchte da kann ich wenig hilfreich sein, hab keine Ahnung welche Authentifizierung Eurer Proxy erwartet.

     

    Vielleicht hat Ovi da ne Idee?

    #4543
    Profilbild von Paco
    Paco
    Keymaster

    hm, also du hast user,password und proxy in deinen Variablen? 

    versuch doch mal user und passwort da raus zu nehmen und dann manuel testen und user/pw mitgeben:

    wget –proxy-user=XXX –proxy-passwd=YYY http://die-kellerkinder.eu

     

    eventuell probier dann auch mal  –proxy-user=domainXXX

     

    ach ja, das manual sagt:

    --proxy-user=user

    --proxy-passwd=password
    Specify the username user and password password for
    authentication on a proxy server. Wget will encode
    them using the `basic' authentication scheme.

     
    keine Ahnung was da jetzt mit basic authentication scheme gemeint ist.
    Na ja und dann hab ich noch das gefunden:
     

    Proxy

    Wget uses the standard proxy environment variables. See: Proxy settings

    To use the proxy authentication feature:

     

    Das passt ja bei dir. Zudem geben die als Beispiel: 

     

    $ wget --proxy-user "DOMAINUSER" --proxy-password "PASSWORD" URL
     
    d.h. nimm doch mal die Authentifizierung aus deinen Variable und übergib die mal so wie hier gezeigt.

    Aber da werfe ich meine Granata IMMER hin!

    #4544
    Profilbild von Stefan
    Stefan
    Moderator

    genau so hab ich das auch schon probiert 🙂

    #4545
    Profilbild von Paco
    Paco
    Keymaster

    du hast also Die Variablen sind auf http:/proxy.corp.com:8080 gesetzt und dann den user und PW als parameter mitgegeben? Und kriegst trotzdem nur error 407 zurück?

    Kommst du an die logs vom proxy ran?

     

    probier mal wget mit -o logfile und -d für debug und poste mal was der ins logfile schreibt, da kann man vielleicht Rückschlüße ziehen.

    Aber da werfe ich meine Granata IMMER hin!

    #4546
    Profilbild von Stefan
    Stefan
    Moderator

    hier die debug info:

    SYSTEM_WGETRC = c:/progra~1/wget/etc/wgetrc
    syswgetrc = C:ProgrammeGnuWin32/etc/wgetrc
    DEBUG output created by Wget 1.11.4 on Windows-MinGW.

    --2011-08-15 06:58:28-- http://www.acxiom.de/
    seconds 0,00, Verbindungsaufbau zu 10.148.1.250:8080... seconds 0,00, verbunden.

    Created socket 1932.
    Releasing 0x009b7220 (new refcount 0).
    Deleting unused 0x009b7220.

    ---request begin---
    GET http://www.acxiom.de/ HTTP/1.0
    User-Agent: Wget/1.11.4
    Accept: */*
    Host: www.acxiom.de
    Proxy-Authorization: Basic c2thc3RuOnhzdzJjZGUz

    ---request end---
    Proxy Anforderung gesendet, warte auf Antwort...
    ---response begin---
    HTTP/1.0 407 Proxy Authentication Required
    Mime-Version: 1.0
    Date: Mon, 15 Aug 2011 04:55:16 GMT
    Content-Type: text/html
    Proxy-Authenticate: NTLM
    Connection: close
    Proxy-Connection: close
    Content-Length: 1771

    ---response end---
    407 Proxy Authentication Required
    Closed fd 1932
    2011-08-15 06:58:28 FEHLER 407: Proxy Authentication Required.
    #4547
    Profilbild von Paco
    Paco
    Keymaster

    also als erstes mal sehe ich dass WGET 

    Proxy-Authorization: Basic c2thc3RuOnhzdzJjZGUz versucht und der Proxy aber
    Proxy-Authenticate: NTLM erwartet und weiter passiert hier nichts :-(
     
    hier wird behauptet NTLM wäre broken mit wget 1.11, probier mal 1.10: 
    http://stackoverflow.com/questions/1125517/using-wget-against-protected-site-with-ntlm
     
    alles was ich noch dazu finden kann sind workarounds, 
    die meisten verwenden einen von diesen zwei proxies: 
    http://www.akiaki.org/zaurus/ntlm/ oder 
    http://ntlmaps.sourceforge.net/ 
    der sich mittels NTLM an deinem Firmenproxy anmeldet und quasi als Mittelsmann 
    zwischen wget und dem FIrmenproxy vermittelt.
     
    Nebenbei bemerkt: mußt du wget verwenden? Was planst du eigentlich? Eventuell wäre eine Alternative besser und einfacher?

    Aber da werfe ich meine Granata IMMER hin!

    #4548
    Profilbild von Stefan
    Stefan
    Moderator

    das problem hab ich bei allem was vom terminal aufs netz zugreifen will.

    Ruby Gems, Perl Skripte, Curl, wget ganz egal.

     

    Ich will das Problem ein für allemal beseitigen.

     

    Ich schau mir den NTLMaps mal an.

    #4549
    Profilbild von Paco
    Paco
    Keymaster

    sag mal wenn ic hdas richtig sehe ist das doch so eine minimale linux shell unter windows, oder? 

    hat die denn nicht eine zentrale Konfiguration wo man den Proxy einstellen kann? Sorry wenn das ne doofe Frage ist aber ich hab noch nie mit sowas gearbeitet… 

    das hier scheint doch das zu sein, oder? http://sourceforge.net/tracker/index.php?func=detail&aid=3033232&group_id=2435&atid=352435

    Aber da werfe ich meine Granata IMMER hin!

    #4550
    Profilbild von Stefan
    Stefan
    Moderator

    nein, das ist die stinknormale Dos Kommandozeile.

    Und die zentralke Konfiguration sollten die Umgebungsvariablen sein, die Windowsweit gelten.

Ansicht von 10 Beiträgen - 1 bis 10 (von insgesamt 10)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.